No results found...

New

?

Loading...

Devices

Compatibility  Compatibility 
  • Device Compatibility  Device Compatibility 
    • Manufacturer
    • Operating System
    • Device
    • Apple
    • iOS 8.0 is required. iOS 8.4 or higher is recommended.
    • The full Skylanders SuperChargers game experience will be playable on Apple TV, iPad Air, iPad Air 2, iPad mini 2, iPad mini 3, iPad mini 4, iPad Pro, iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 6s, iPhone 6s Plus and iPod touch 6.  Fans with iPhone 5/5C, iPad 4, iPad 3 and iPad mini can enjoy the full game, excluding online functionality.
  • Device Compatibility  Device Compatibility 
    • Manufacturer
    • Operating System
    • Device
    • Apple
    • iOS 7 or higher
      • iPad® (3rd Generation)
      • iPad® (2nd Generation)
      • iPad Air™
      • iPad Air™ 2
      • iPad mini™
      • iPad mini™ 2
      • iPad mini™ 3
    • Amazon
    • Fire OS 4 or higher
      • FIRE HD 6, FIRE HD 7 (2014)
      • FIRE HDX 8.9 (2014)
      • KINDLE FIRE HDX 7", 8.9" (2013)
    • Samsung
    • Android™ 4.4, KITKAT
      • GALAXY NOTE 10.1 (2014)
      • GALAXY NOTE PRO 12.2
      • GALAXY TAB PRO 8.4, 10.1, 12.2
    • Google™
    • Android™ 4.4, KITKAT or higher
      • NEXUS 9 (2014)
      • NEXUS 7 (2013)
    • NVIDIA®
    • Android™ 4.4, KITKAT or higher
      • SHIELD™ TABLET
  • Superchargers
    • Apple

      iOS 8.0 is required. iOS 8.4 or higher is recommended.
      The full Skylanders SuperChargers game experience will be playable on Apple TV, iPad Air, iPad Air 2, iPad mini 2, iPad mini 3, iPad mini 4, iPad Pro, iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 6s, iPhone 6s Plus and iPod touch 6.  Fans with iPhone 5/5C, iPad 4, iPad 3 and iPad mini can enjoy the full game, excluding online functionality.
  • Trap Team
    • Apple

      iOS 7 or higher
      • iPad® (3rd Generation)
      • iPad® (2nd Generation)
      • iPad Air™
      • iPad Air™ 2
      • iPad mini™
      • iPad mini™ 2
      • iPad mini™ 3
    • Amazon

      Fire OS 4 or higher
      • FIRE HD 6, FIRE HD 7 (2014)
      • FIRE HDX 8.9 (2014)
      • KINDLE FIRE HDX 7", 8.9" (2013)
    • Samsung

      Android™ 4.4, KITKAT
      • GALAXY NOTE 10.1 (2014)
      • GALAXY NOTE PRO 12.2
      • GALAXY TAB PRO 8.4, 10.1, 12.2
    • Google™

      Android™ 4.4, KITKAT or higher
      • NEXUS 9 (2014)
      • NEXUS 7 (2013)
    • NVIDIA®

      Android™ 4.4, KITKAT or higher
      • SHIELD™ TABLET

Wi-Fi connection required to download content. Minimum storage required: 3GB

Please Note: iPad 2 or earlier is not supported.  All other tablets or phones are NOT compatible.